Login issues, can't access the video content (resolved)

Hi guys,

I’m logged in and would like to access the Dicktionary content not from YouTube, but via timeghost. tv. If I click any of the videos, this page appears:


I cannot click the “Login” button on the right side, it will just turn red when I mouse-over it. And as I said, I am logged in. I’ve tried another browser, but I’ve got the same result. For all I know, my subscription is valid and active. If I look at my account, it only shows this:


This seems to be my Kickstarter pledge and my current Patreon pledge (I pledged 3$ a while ago and it was turned into the 4.50$ combo tier) is not on there. Is that the issue?

I checked, you have two user accounts as you use different emails on Kickstarter and Patreon. I upgraded the account you’re using to reflect your Patreon pledge instead. This might however lead to some problems if you change your Patreon pledge, so I’ll talk to Sampath and try to get your accounts merged without losing any user data and history.

If it still isn’t working after my update, please mail us at community@timeghost.tv so that both Sampath and I get the mail.

Thanks, I can access the videos now. If you cannot merge the accounts without any loss, that’s okay. Seeing as the site is still brand new, I wouldn’t really mind losing the badges and history.

On an unrelated note: I cannot play the videos because they seem to start twice with a bit of delay (roughly one second) and then overlap. I can see the video starting properly, and then a second audio stream starts in the background. I have tried several videos, various browsers (Vivaldi, Firefox, Opera, Edge) and even Windows and Linux. There is probably a bug in the server software, so it would be good if you could look into that. If you need me to provide a screen capture video or something, I’m sure I can do that if need be.

I had something similar happen. I thought it was just a one time quirk but maybe not.

1 Like

@Sampath - can you please look into the above issue with the video player.

1 Like

Actually I found the videos on the site to be buggy as hell too. Lots of pauses and problems with sound and video syncing.

We’re working on it - we will replace the current video player solution with the Amazon cloud player, currently it’s the native browser player that gets prompted and this seems to be creating some issues. Our apologies for the inconvenience.

1 Like

Sure. I will replace all the videos with a new system in next 24 hours.

1 Like

Video echo issue is fixed now.

1 Like

Hi, I seem to be a little late to the party with this one,

However I seem to be having the same issue as described above, I thought it might just be a small issue with the website so left it for a while, but the issue is still continuing.

I was an original Kickstarter backer ($3) as well as a Patreon supporter since inception ($3) (now $4.50? or something). However on my account information is is saying that my account is not active.

see image:


If anyone could help me out, that would be ace.

@tomellinger, should be fixed now - there was an error in updating your info at end of the month, sorry for the inconvenience.

@Sampath - this seems to be recurring - some memberships are lapsing despite that they should stay active can you look into what the problem is, please.

1 Like

Same issue for me, a one-month manual subscription (9$) ended on April 26th and I cannot access the content right now.

Fixed your settings manually too…

1 Like

For my account there seems to be a disconnect between Patreon, where I’m in good standing for $4.50 a month, and here, where there are four entries and all are expired. If there’s something I need to change, please instruct.

@Sampath - please look at James account as well - he seems to be hit by the problem too.

It seems I have a similar issue. I have signed up and paid for a subscription that has gone through my bank. But I cannot access any of the videos. On my account tab, it says there is no subscription and no payment that has gone through.

Hey, there! I also can’t access any content. I’ve got a TIMEGHOST ARMY SPECIALIST subscription on Patreon. In my account menu on timeghost.tv it says it’s not active, and that I’m not subscribed. But on Patreon it says that my pledge is active.

I’m sorry to say that the issue has happened again, there is definitely a disconnect between Patreon and here. guessing this is going to happen every month? Is there anything we can do to stop this happening?


I have the same issue.

@Sampath is working on it - we’ve discovered the problem and will have it fixed very soon.